Page 1 sur 2

Pb synchronisation NAS D-link 325

Posté : dim. 30 juil. 2017 18:12
par trustboys
Bonjour,

j'ai voulu synchroniser mon nas D-link 325 à l'application videotéque comme expliqué dans l'article ci dessous.

Seulement 1er difficulté : je ne sais pas sur quel port est ouvert le Nas

je sais qu'il est sous l'adresse IP : 192.168.0.32, j'ai essayé les port 80, 8080 et 5005 mais aucune synchronisation ne fonctionne voici le retour du log :

Url for wedav request: https://192.168.0.32:80/
Erreur de connexion au serveur : System.Net.WebException: Le délai d'attente de l'opération a expiré.
à System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
à System.Net.HttpWebRequest.GetRequestStream()
à VideothequeNas.AdvancedWebdav.listVideos(ArrayList& videos, String remoteFilePath)
Erreur lors de la récupération des vidéos : System.Exception: Une erreur est survenue durant la connexion au serveur, vérifiez les paramètres
à VideothequeNas.AdvancedWebdav.listVideos(ArrayList& videos, String remoteFilePath)
à VideothequeNas.AdvancedWebdav.getVideos(String scheme, String url, String directory, String port, String userName, String password)
à VideothequeNas.VideothequeNas.run(String scheme, String url, String directory, String port, String userName, String password)

merci pour votre aide


http://www.universfreebox.com/article/3 ... nt-les-NAS

Re: Pb synchronisation NAS D-link 325

Posté : dim. 30 juil. 2017 19:35
par olixelle
Hello,

sais tu si ton NAS est en HTTPS par défaut ?

Re: Pb synchronisation NAS D-link 325

Posté : dim. 30 juil. 2017 20:50
par trustboys
Malheureusement, je sais pas ou trouver ça dans le paramétrage de mon Nas.

En tous cas, j'ai essayé les 2 types sur l'application "vidéotéque nas" pour le paramétrage :

- https
- http

je n'ai pas activé l'option FTP, je fonctionne seulement sur l'option UPNP.

Voici les paramétrages activées sur le nas :

CIFS / FTP / NFS / Webdad

ça vous aide ?

Re: Pb synchronisation NAS D-link 325

Posté : lun. 31 juil. 2017 11:03
par olixelle
Hello,

c'est le webdav qu'il faut utiliser, pourrais tu aller dans cette section sur ton NAS et me donner les paramètres que tu vois ?

Note : si tu mets le mode https, essaye avec le port 465

Re: Pb synchronisation NAS D-link 325

Posté : lun. 7 août 2017 18:12
par trustboys
CI dessous mon paramètrage

http://imgur.com/a/1ygCo

Re: Pb synchronisation NAS D-link 325

Posté : jeu. 10 août 2017 07:32
par olixelle
Hello,

ca ne m'aide malheureusement pas :(

Re: Pb synchronisation NAS D-link 325

Posté : sam. 12 août 2017 16:54
par trustboys
Bonjour,

Malheuresement c'est les seules informations affichées quand je suis dans le paramètrage du nas mais peut être savez vous lire les informations du fichier log de l'application. Je pense qu'on pourrais avoir des informations. Voici le message du log après ma tentative avec les bon paramètres :

le logiciel affiche " recherche video " pendant au moins 2 min de suite comme si la recherche était lancée et au bout d'un certain temps, voici ce qui s'affiche dans l'onglet général :

Recherche de vidéos
Erreur lors de la récupération des vidéos

onglet détails :
Url for wedav request: https://192.168.0.32:80/
Erreur de connexion au serveur : System.Net.WebException: Le délai d'attente de l'opération a expiré.
à System.Net.HttpWebRequest.GetRequestStream(TransportContext& context)
à System.Net.HttpWebRequest.GetRequestStream()
à VideothequeNas.AdvancedWebdav.listVideos(ArrayList& videos, String remoteFilePath)
Erreur lors de la récupération des vidéos : System.Exception: Une erreur est survenue durant la connexion au serveur, vérifiez les paramètres
à VideothequeNas.AdvancedWebdav.listVideos(ArrayList& videos, String remoteFilePath)
à VideothequeNas.AdvancedWebdav.getVideos(String scheme, String url, String directory, String port, String userName, String password)
à VideothequeNas.VideothequeNas.run(String scheme, String url, String directory, String port, String userName, String password)

Onglet réponse webdav : vide la page reste blanche.

Une idée ?

Merci

Re: Pb synchronisation NAS D-link 325

Posté : sam. 12 août 2017 17:22
par trustboys
http://imgur.com/a/o1CoC

Voici une photo de mon paramètrage vidéotéque :

j'ai également essayé avec les champs utilisateur et mots de passe renseignés :

- J'ai essayé Utilisateurs : Admin et mots de passe : celui pour me connecter à mon nas
- j'ai également essayé avec :

utilisateur : Admin

MP : Admin

et toujours le même message d'erreur

Re: Pb synchronisation NAS D-link 325

Posté : dim. 13 août 2017 12:32
par olixelle
Hello,

peux tu essayer en laissant le port vide ? 80 est le port HTTP et non HTTPS

Re: Pb synchronisation NAS D-link 325

Posté : lun. 14 août 2017 07:16
par trustboys
Bonjour,

je viens d'essayer avec le port vide --> message du logiciel le champ port doit être rempli.

j'ai également essayé avec le port 465 en https comme tu me l'a dit précédemment et toujours rien :s.

d'autres idées ?

merci